Is Your Browser Out of Date for eCentral?

eCentral customers using an Internet browser lower than Internet Explorer 7 and Firefox 3 will not be able to log on to eCentral after December 1, 2009. It is recommended that practices upgrade to the latest versions; Internet Explorer 8 or Firefox 3.5 for optimal performance.

The upgrade is necessary in order for eCentral to utilize the latest technology and remain secure.

Check your current version by clicking ‘Help’ in your browser, then either ‘About Internet Explorer’ or ‘About Firefox’. If you have an older version, you can upgrade today by clicking Internet Explorer 8 or Firefox 3.5 and following the instructions on the respective Web sites.

When upgrading, please keep in mind that the DXWeb Toolbar requires Internet Explorer.

If you need assistance, please contact our Customer Support Team at 800-734-5561.



Author: Damon Graves
Published: 10/26/2009
Contact Us