Dentrix eServices Compatibility with Windows 10

All Dentrix eServices are compatible with Windows 10 and .net 4.6 – including eClaims, PowerPay LE, eCentral and eSync.

However, if you are already using Windows 10 and want to use PowerPay, it will not install – Dentrix customers currently using PowerPay can upgrade to Windows 10 at any time. Customers considering PowerPay for a Windows 10 system should consider PowerPay LE as a temporary solution instead.

Again, before you upgrade to Window 10 or .net 4.6, we recommend you do a full assessment of your practice software and technology to ensure they are fully compatible. If you have any questions, please contact us at 800.336.8749 or visit http://dentrix.com/windows10.



Author: Bruce Herbert, eServices Product Marketing Manager
Published: 07/31/2016
Contact Us