New OS Requirements Coming Soon

Effective with the release of Dentrix G6.5 (coming in Q3 2017)—and for future, planned Dentrix versions—the following minimum operating systems will be supported:

Servers
Windows Server 2016
Windows Server 2012 Standard/Datacenter (R1/R2)
Windows Server 2008 Standard/Enterprise/Datacenter (R2 SP1)

Computers
Windows 10
Windows 8.1 Professional/Enterprise
Windows 7 Professional/Enterprise/Ultimate (SP1)

These versions are necessary to support your data transmission using the latest transport layer security (TLS 1.2).

Dentrix passwords required for all users

In the first half of 2018, Dentrix will begin requiring passwords for all users with minimum complexity requirements. In anticipation of that release, please prepare today by ensuring your passwords are enabled and that all users have appropriate access to the various areas of Dentrix. You can also start using the new complexity requirements now, which include (1) a minimum of eight characters and (2) at least one uppercase and one lowercase alpha character, at least one numeric character and at least one special character (e.g., #@$*).



Author: Brad Royer
Published: 07/19/2017
Contact Us