eClaims is designed to work in coordination with the following clinical and practice management software.

Note: System requirements are subject to change according to current computer industry standards.

An Internet connection is required; high-speed is recommended. A 32-bit Twain-compliant scanner is required for sending existing paper documents electronically.

Dentrix

Version 11.0 through G3
Limited functionality (call 800.734.5561 for details)

Version G4 and newer
Full functionality

In addition to eClaims, you must be on Dentrix G5 to receive eEOB. You must also download and install eSync 3.6 or higher and the eEOB plug-in. Click here for an outline of all system requirements.

Dentrix Enterprise

Version 3.5 and newer
Limited functionality (call 800.734.5561 for details)

Easy Dental

Version 2005 and newer
Limited functionality (call 800.734.5561 for details)

DentalVision Pro

Version 11 and newer
Limited functionality (call 800.734.5561 for details)

DentalVision Enterprise

Version 8 and newer
Limited functionality (call 800.734.5561 for details)

OMSVision

Version 7 and newer
Limited functionality (call 800.734.5561 for details)

PerioVision

Version 10 and newer
Limited functionality (call 800.734.5561 for details)

EndoVision

Version 10 and newer
Limited functionality (call 800.734.5561 for details)

Call Us Today

800.734.5561

Request a Demo

Contact us for an online demonstration

eServices Support

Get in touch with eServices Support